RegisterRegister  LoginLogin
Site Search:
HOME HAEMOPHILIA ASP WEB DIRECTORY FORUM 23/06/17
ASP 3D Art Haemophilia Web Directory
Latest Forum Posts
Join Mailing List
Your E-mail Address


  Active TopicsActive Topics  Display List of Forum MembersMemberlist  Search The ForumSearch  HelpHelp
Breathofair Login Manager
 Breathofair Forums : Breathofair Login Manager
Subject Topic: Error on logging in Post ReplyPost New Topic
Author
Message << Prev Topic | Next Topic >>
eversios
Newbie
Newbie


Joined: 13 January 2005
Location: United States
Online Status: Offline
Posts: 4
Posted: 26 January 2005 at 8:58am | IP Logged Quote eversios

I am running server 2003 and have the IIS running. I unzip all the files of the login manager into the root folder. Then access the page via IE. I get to login_user.asp with no problems. I enter the Administrator and letmein and insteasd of letting me in, I get this error:

Microsoft OLE DB Provider for ODBC Drivers error '80004005'

[Microsoft][ODBC Microsoft Access Driver] Operation must use an updateable query.

/login_user.asp, line 262

Any ideas? This happens to my XP Pro box too, when I install IIS on it and configure it for web pages.

Thanks.

Back to Top View eversios's Profile Search for other posts by eversios
 
AirHead
Admin Group
Admin Group
Avatar
Breathofair Developer

Joined: 12 March 2004
Location: England
Online Status: Offline
Posts: 106
Posted: 26 January 2005 at 9:58am | IP Logged Quote AirHead

ussually this error suggests that the database is either set to read only. download the database and right click properties and make sure the read only is unchecked

also check that the folder that holds the database has read,write, modify permssions.


__________________
Take a breath of air
Back to Top View AirHead's Profile Search for other posts by AirHead Visit AirHead's Homepage
 
eversios
Newbie
Newbie


Joined: 13 January 2005
Location: United States
Online Status: Offline
Posts: 4
Posted: 26 January 2005 at 11:06am | IP Logged Quote eversios

I checked that before I posted, Sorry, I didnt' mention it.

I Fiddled with the IIS some and got some pages to work, Others won't because the .. is not allowed for moving up a folder in the scripting.

 

 

Back to Top View eversios's Profile Search for other posts by eversios
 
AirHead
Admin Group
Admin Group
Avatar
Breathofair Developer

Joined: 12 March 2004
Location: England
Online Status: Offline
Posts: 106
Posted: 26 January 2005 at 4:19pm | IP Logged Quote AirHead

oo ok...

have you tried a fresh downloaded version / uploaded version as file can become corrupt when using ftp.?

also can you post the section around that line.. Few lines above .. o i can see what update it is tried to do. are you using V1 B2 access?


__________________
Take a breath of air
Back to Top View AirHead's Profile Search for other posts by AirHead Visit AirHead's Homepage
 
eversios
Newbie
Newbie


Joined: 13 January 2005
Location: United States
Online Status: Offline
Posts: 4
Posted: 26 January 2005 at 4:40pm | IP Logged Quote eversios

The error with the .. to go up a directory happens on a lot of pages in the Admin folder. such as common.asp.

<!--#include FILE="../code_check.asp" -->
<!--#include FILE="../languages/english.asp" -->
<!--#include file="../send_mail_function.asp" -->

any time the pages in the admin folder try to go up a directory, this error occurs:

Active Server Pages error 'ASP 0131'

Disallowed Parent Path

/admin/Common.asp, line 342

The Include file '../code_check.asp' cannot contain '..' to indicate the parent directory.

I can get around it in a way by copying these .asp pages into admin folder, then changing the <!--#include file="../send_mail_function.asp" --> to <!--#include file="send_mail_function.asp" -->

Kinda a cheat around, but that means I need to do that to every page in the admin folder.

Back to Top View eversios's Profile Search for other posts by eversios
 
AirHead
Admin Group
Admin Group
Avatar
Breathofair Developer

Joined: 12 March 2004
Location: England
Online Status: Offline
Posts: 106
Posted: 26 January 2005 at 6:45pm | IP Logged Quote AirHead

your host has disallowed then .. not sure why. can understand from root up.. but not from folders below

__________________
Take a breath of air
Back to Top View AirHead's Profile Search for other posts by AirHead Visit AirHead's Homepage
 
ReggieB
Newbie
Newbie


Joined: 22 July 2005
Online Status: Offline
Posts: 1
Posted: 22 July 2005 at 12:42pm | IP Logged Quote ReggieB

Have a look at this  http://support.microsoft.com/default.aspx?scid=kb;en-us;2264 74 article on the Microsoft support site.

Basically, you need to "Enable Parent Paths" in your IIS WebSite or Virtual Folder properties (Configuration > Options)

Back to Top View ReggieB's Profile Search for other posts by ReggieB
 

If you wish to post a reply to this topic you must first login
If you are not already registered you must first register

  Post ReplyPost New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You can vote in polls in this forum



This page was generated in 2.4375 seconds.
| Contact Site | Privacy Statement | Jobs @ This Site | Advertise | Site Rules and Policies |
2,384,896 Visitors Since 4/10/02
© 2000-2005 Aaron Hockaday
80 Active Users